Kawasaki Ninja Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Morning everyone,
I have a 2000 ZX-6R that when I bought it the guy mentioned that it's been running rich. He put a new yoshi pipe on it. It was running fine for the last couple of weeks but the other day I went to go for a ride and the bike starts fine but will die when I give it any throttle. Applying the choke will ramp up the rpm but still does when applying the throttle. I've bench tested my fuel pump and I have new carb kits and spark plugs in the way. I've also replaced the battery. I guess my question is am I in the right track or am I showing how green I am with these?
 

·
Moderator
Joined
·
1,458 Posts
Carb issue is the best direction to look at. Carbs probably need to have all the adjustment screws turned and put back in the same exact location. Run carb cleaner through carbs as well. Def sounds like the carbs are dirty
 

·
Moderator
Joined
·
1,458 Posts
Any time. Do You have mechanical experience at all? If so I'd recommend a carb tear down and full cleaning because the issue but also because the bike is older. Clean the jets ridiculously good and clean the components of the carb itself. You can make a soda blaster that will help you clean most of the carb pretty cheap like 6-7.00 US dollars if you already have a air compressor. I posted
How to do that a while back. It works really good. For the jets use a super thin wire or a jet cleaner. I find a Bristol off a wooded wire brush works great. If you can't hold the jet up To a light and see through it then it is not clean and keep working on it.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top