Kawasaki Ninja Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter · #1 ·
So I was leaving work today, and I let my bike warm up for like 5 min as I normally do.. I hoped on an began to ride home... Thank god I had to hit the brakes at a casual stop before I hit the freeway I noticed my brake didnt do ANYTHING it felt like my clutch when I pulled it in.. I have no idea to as why this would happen. I tried checking of something was stuck but didn't find anything.. I had to "pump the handle brake" to get it to work if that makes seance
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #2 ·
Any sense*

It kinda belt like when you bleed a cars brake fluid, how you have to keep pressing the brake before it works...

PS I'm a noob at bikes, most mechanical thing I've done was change my own oil any advice or thoughts are appreciated. I drive a 2010 ninja 250
 

·
Registered
Joined
·
2,270 Posts
calialex said:
Any sense*

It kinda belt like when you bleed a cars brake fluid, how you have to keep pressing the brake before it works...

PS I'm a noob at bikes, most mechanical thing I've done was change my own oil any advice or thoughts are appreciated. I drive a 2010 ninja 250
Might need to bleed them through as you might have an airlock,I'd replace the fluid and maybe the seal because you could have water in there too !
 

·
Registered
Joined
·
1,480 Posts
How's your brake fluid level?
Are your brake rotors/pads still within serviceable limits?

Depending on how many miles you have on the bike and how hard you ride/use the brakes one or all the above items could be your problem.

Start by checking your brake fluid level. Kawasaki recommends replacement @ 2 years or 15k miles. Also make sure you have no leaks.
 

·
Registered
Joined
·
125 Posts
I'm having pretty much the same problem. I have to bleed the brakes before every ride. I have tried everything mentioned above and none solved the problem. My next step is to replace the master cylinder.
 

·
Registered
Joined
·
2,270 Posts
NDog65 said:
I'm having pretty much the same problem. I have to bleed the brakes before every ride. I have tried everything mentioned above and none solved the problem. My next step is to replace the master cylinder.
Are the slider seals ok,you might need to replace caliper pistons seals etc
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #8 ·
I'll have to check my fluid, idk why it would be any of those things since I just hit 5k miles on it. ill check again for any leaks tho.. I'll update guys, thanks again!!
 

·
Registered
Joined
·
2,270 Posts
calialex said:
I'll have to check my fluid, idk why it would be any of those things since I just hit 5k miles on it. ill check again for any leaks tho.. I'll update guys, thanks again!!
Could be a bad batch of seals etc speak to the main dealer and see if there are any recalls on the bike!
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top