Kawasaki Ninja Forum banner
1 - 20 of 94 Posts

·
Registered
Joined
·
1,795 Posts
Discussion Starter · #1 ·
Well this is a big deal. Maxton will stop racing in 2012. The 2011 season will be the last time racing will be held in Maxton North Carolina. Hopefully there will be a new track opening some where. But for now Maine is it.
It is a complicated issue but the bottom line is this is the last year for it at Maxton. :mad: Welcome to ECTA

I will be running every race till the end and keep everyone updated. So I am looking forward to a very exciting racing season for 2011 . After that I will have to go where ever the racing takes me. The thing is to keep pushing the 250 Ninja to faster top speeds .
 

·
Registered
Joined
·
1,795 Posts
Discussion Starter · #4 ·
The community of land speed racers is very close. We all talk to each other wawy from the track. For 2011 we are OK .and for 2012 we will just have to find another track.

There must be a village looking for idiots someware
 

·
Registered
Joined
·
1,795 Posts
Discussion Starter · #6 ·
I will ,There is already a track in Maine. That could be turned into a once a year week of speed thing. Or we will find another track .OR more than one track and have a travailing series. This just hit the fan yesterday so who knows. The town of Maxton is going to loose a LOT of cash from the race five times a year. Maybe it will all work out. Either way I am still going to race some place.
 

·
Registered
Joined
·
1,795 Posts
Discussion Starter · #7 · (Edited)
Day one is over. Brutal is all I can say. First I had some carb problems and had to fiddle with that. Then the wind picked up 20 mph cross winds with gusts. Then when we started to run. OIL DOWN we had to clean up a 1/4 mile of trans fluid. Then I got to run
I just wanted to make an easy pass to feel out the bike 97mph fighting wind .but the engine cut off then turned on again. I found a loose wire at the power switch . Got back in line and more OIL on the track.An engine let go. I was second in line to go and the wind picked up even more. So they shut us down.

I feel good. I got all the little problems sorted I hope .and I will be ready to go full bore tomorrow. I also had a visit from Da Blue1. It was great to see him. I hope he got some good photos from today. I had my hands full and did not get any photos. Hope to run tomorrow.
 

·
Registered
Joined
·
1,480 Posts
I had the opportunity to witness some of the action today. I saw some new bikes and cars and i also saw some of the same ones from last year. I got to talk to Racer X and get some pics of his bike during the down time on the strip. let me tell you...his bike is awesome. he has morphed it into something unique. It's one of those creations you have to see up close. A couple of wings, aerilons and a rudder and the bike could have flew with the strong winds today. Good luck tomorrow X. The tail wind is a comin'.

Just some pics of the Dark Horse Special
 

Attachments

·
Registered
Joined
·
1,480 Posts
Something different from last year was a young female rider on an Aprilia RS50 and a car made from a 1944 Navy Aircraft Fuel Pod. I must say, I was surprised to see a big ass Cadillac Eldorado representing in the front wheel drive class.
 

Attachments

·
Premium Member
Joined
·
4,247 Posts
That is awesome guys!
Good luck with everything tomorrow X, go kick some ass!!

Blue, thanks for the photos, they look great.
 

·
Premium Member
Joined
·
6,846 Posts

·
Registered
Joined
·
1,795 Posts
Discussion Starter · #14 ·
Well the first meet is over . That was tough. I got four runs in .One on Saturday and three on Sunday. Saturday I just had to sort a couple minor problems out the rest of the day was spent waiting in the sun.With 20 mph wind plus sun equals sunburn and dehydration. Then Sunday was good . First run was still a break in run .But I wanted to at least go 100 mph. So I hit 101. Then I put on the bottle and hit the nitrous at the 3/4 mark .Still going easy and went 113 with just a tap of the button. Then with 5 minutes before the end I got one of the last runs of the weekend. I got 119.428 mph .That was just pushing the button and letting off . I have not taken the motor down yet to check it But from my data it looks like the clutch held. I was at 12480 rpm on the 113 pass. I did not get data on the 119 pass. I will have to sort that out . Next meet is in a month . Lots to do to run again.
 

·
Premium Member
Joined
·
6,846 Posts

·
Registered
Joined
·
1,795 Posts
Discussion Starter · #19 ·
I found a place that will make a clutch basket and cover . Then I will have the same clutch as a 636. But it cost 1400 bucks.
 
1 - 20 of 94 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top