Kawasaki Ninja Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
I installed my danmoto exhaust that arrived yesterday. Sounds awesome. I donno if its just in my head or because the exhaust is so much louder but it seems like it hesitates. If im cruising at 4 grand then go WOT, it seems to take a split second then go. Also seems slower to accelerate at WOT from 120km/hr to 140 km/hr Could it be running too lean? Is this normal? Maybe its just all in my head? Thanks.
 

·
Premium Member
Joined
·
4,247 Posts
Couple of questions, have you made any changes to the carbs or only done the exhaust?
If you have not done anything, I would say the bike is running lean. A new exhaust makes the bike breath better but if there is not enough fuel then you will get hesitation.
Without more info on your other mods, we are only guessing.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #5 ·
Thanks guys, I spent all last weekend trying to find washers to shim with but no luck. I was going to shim the needles before I put the exhaust on but am having difficulties finding washers.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #7 ·
Found some at an automotive store I used to work at. Home hardware didn't have any neither did home depot. I put one on each needle, they were .020 thick. Took her for a drive and seems back to normal. No more hesitation when trying to accelerate slightly from a cruise. Finally a nice sunny day here on Vancouver Island (the worst summer ever), Gunna go for a cruise. Thanks guys!:thumb:
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top